Adding new apps not working

I submitted a ticket, but was wondering if this is a common thing. I click the add new app, fill out the information and click build app and it does nothing. I tried in chrome and edge, I also tried it in incognito mode. If it is down or having issues at the moment is there a facebook group or page where I can see the status?

Same issue here^^^ Paid for it and can’t and it’s completely unresponsive.

I created a ticket. No response yet, but I think it’s a different time zone i believe. I am also hoping that this is fixable and doesn’t happen again.

Awesome. It won’t let me contact email support as apparently you need to have made an app for that, which we’re now unable to make :stuck_out_tongue:

Hope you hear back soon

I am golden again. Support took care of my issue. I sent them a message too to let them know you are unable to message them and gave them a link to the post. Hopefully you should be good soon. if not there email is

It won’t let me create the first app