Error when trying to grant access to the AppMySte app on WordPress

Hi. I’m trying to complete the setup of AppMySite on my Wordpress website. I’ve already completed the steps in appearance, connectivity and install plugin. Now I’m having trouble granting access with WordPress application to get the password. Any pointers would be appreciated.

I am having the same issue. What have you tried so far?

I’ve created the Application Password in the Admin User Profile on my site, entered the admin username in the AMS connectivity section, and added the Application Password generated on my site. Is there something I’m missing?

I’ve passed 7/9 of the Troubleshooting tests.

Any guidance from the Community would be appreciated! Thank you!

I resolved the problem. It was bring caused by having url settings in the settings>general.

I had the site url with https://www. And the WordPress admin panel as https://

That was causing the issue for me. As soon as I made them both the same everything started working perfectly. You have to make both urls have the same structure.

Like this:

Site url: https://www.
Admin url: https://www.

Or

Site url: https://
Admin url: https://

Thanks for the reply! I checked my URL settings and both the site URL and admin URL are the same (https://). The error message I’m getting says I’m not logged into the site, which I clearly am, and I’ve double-checked the username, which is also correct. Hmm.

Any suggestions?

1 Like

Your ip might be blocked by the host. My ip was also being blocked by a new host from a site I’m developing and was having trouble logging in. I had to call the host and have them whitelist my ip.

Or as in my case, I had to simply disable the “Application Passwords” tab in Wordfence.

I was having the same issue :frowning: I tried the API keys from Woocommecerce in other systems, and they were working correctly.

I also tried the Application password inside my own Admin user, and that passes the auth verification but fails the “Troubleshooting” tests with 3/11 Tests Passed

I then disabled Defender Pro plugin, still the same.

I ended disabling another security service (CloudFilt) and that finally allowed the tests to pass. Even the Woo API authentication passed after this.

Could @AppMySite support provide us with a list of IP’s that we need to whitelist in our security plugins to avoid this kind of conflicts?

@synergetic Did you try contacting their support team regarding your connectivity issues? They’re usually able to solve problems such as the one you’re facing.

Hi @sheen I prefer to troubleshoot by myself first, to avoid overloading support. And as you can see in my last message, I managed to solve it, but at the expense of disabling the DDoS/Bot/Scrapping protection service I use (CloudFilt)

I am facing the same problem

Have contacted them thrice in last three days but did not get any resolution